嵌入式爱好者

查看: 370|回复: 2

[Ubuntu] 编译环境搭建失败

[复制链接]

5

主题

18

帖子

52

积分

i.MX6Q通行证

扫一扫,手机访问本帖
发表于 2019-1-30 14:01:59 | 显示全部楼层 |阅读模式
本帖最后由 fendoushuai 于 2019-1-30 14:29 编辑


在virtualBox中新安装了Ubuntu12.04,在这个环境下安装fsl-imx-x11-glibc-x86_64-meta-toolchain-qt5-cortexa9hf-neon-toolchain-4.1.15-2.1.0.sh时提示“Error: Installation machine not supported!”见下图所示,这是什么原因?需要更改什么配置吗?

2019-01-30_135718.png


使用的文件分别是
OKMX6Q-C、OKMX6DL-C_Qt5.6+Linux4.1.15用户资料(工业级商业级共用)_20181023\工具\ubuntu-12.04-desktop-i386.iso
OKMX6Q-C、OKMX6DL-C_Qt5.6+Linux4.1.15用户资料(工业级商业级共用)_20181023\Linux\工具\fsl-imx-x11-glibc-x86_64-meta-toolchain-qt5-cortexa9hf-neon-toolchain-4.1.15-2.1.0.sh


应该是Ubuntu的镜像文件版本不对,要安装64位的才行。
回复

使用道具 举报

2

主题

3494

帖子

3146

积分

发表于 2019-1-30 14:27:47 | 显示全部楼层
您好
您是否在我们论坛下载的环境,我们论坛有搭建好的环境可以按照手册直接进行编译http://bbs.witech.com.cn/forum.php?mod=forumdisplay&fid=80
技术支持电话:0312-3119192
技术支持邮箱:Android@forlinx.com
点评回复 支持 反对

使用道具 举报

0

主题

3

帖子

10

积分

i.MX6Q通行证XX18通行证

发表于 2019-2-19 13:09:32 | 显示全部楼层
这个问题我刚遇到了,原因是ubuntu版本不合适,你在Ubuntu12.04 的32位版本上,装X64的交叉编译是不行的。建议换64位的Ubuntu12.04,iso文件论坛里有,换了就好了。
点评回复 支持 反对

使用道具 举报

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|飞凌嵌入式 ( 冀ICP备12004394号-1

GMT+8, 2019-4-23 11:04

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表