嵌入式爱好者

查看: 412|回复: 7

[Linux] OKMX6UL-C开发板 连接网络之后“ping”无法ping通

[复制链接]

3

主题

12

帖子

24

积分

i.MX6UL通行证i.MX RT通行证

扫一扫,手机访问本帖
发表于 2019-4-29 12:14:13 | 显示全部楼层 |阅读模式
本帖最后由 wforest68 于 2019-4-29 12:15 编辑

1、设置好网络后从界面执行“ping”无法ping通(返回信息是包全部丢失),但是从PC机可以ping到开发版并可以实现telnet连接
2、插入SD卡之后还需要monut吗?直接插入后无法找到SD

3、连接wifi后也无法ping通网关(返回信息是包全部丢失)

4、怎么配置rtl8723bu的bluetooth??看资料里面没有讲怎么配置蓝牙,也未从源码中看到相关rtl8723bu的蓝牙的驱动,是否可以通过相关的说明及驱动。
回复

使用道具 举报

3

主题

12

帖子

24

积分

i.MX6UL通行证i.MX RT通行证

 楼主| 发表于 2019-4-29 12:29:50 | 显示全部楼层
刚才又测试一下,demo中的wifi无法连接路由器,总是提示“please check passord or dhcp server of route device is wroking”,我连接的wifi是公司的wifi,很多人都在使用的,确定名称及密码没有错误

点评

您好, 1.请检查一下PC机是不是设置了防火墙,可以临时关闭一下再试 2.请问是使用的高速卡吗?无法找到SD卡是报什么错误,可以把调试信息发出来。 3.开发板IP和路由器是在同一网段下吗 4.Linux3.14.38有蓝牙的测  详情 回复 发表于 2019-4-29 15:02
点评回复 支持 反对

使用道具 举报

0

主题

30

帖子

165

积分

AM5718通行证AM335x通行证i.MX6UL通行证i.MX RT通行证i.MX6Q通行证XX18通行证TCU通行证FCU1401通行证FCU1301通行证FCU1101通行证

发表于 2019-4-29 15:02:35 | 显示全部楼层
wforest68 发表于 2019-4-29 12:29
刚才又测试一下,demo中的wifi无法连接路由器,总是提示“please check passord or dhcp server of route d ...

您好,
1.请检查一下PC机是不是设置了防火墙,可以临时关闭一下再试
2.请问是使用的高速卡吗?无法找到SD卡是报什么错误,可以把调试信息发出来。
3.开发板IP和路由器是在同一网段下吗
4.Linux3.14.38有蓝牙的测试方法。linux4.1.15手册中没有写。

点评

1、SD卡的问题已解决,是个老卡,估计是系统识别不了(在WIn10下能识别,能使用); 2、网络ping通的问题已解决,是线插头有点问题,重新拔插一遍好了; 3、WIFI的问题没解决,试了能想到的方式都没有解决,在te  详情 回复 发表于 2019-4-29 17:21
点评回复 支持 反对

使用道具 举报

3

主题

12

帖子

24

积分

i.MX6UL通行证i.MX RT通行证

 楼主| 发表于 2019-4-29 17:21:31 | 显示全部楼层
本帖最后由 wforest68 于 2019-4-29 17:38 编辑
WangSai 发表于 2019-4-29 15:02
您好,
1.请检查一下PC机是不是设置了防火墙,可以临时关闭一下再试
2.请问是使用的高速卡吗?无法找到 ...

1、SD卡的问题已解决,是个老卡,估计是系统识别不了(在WIn10下能识别,能使用);
2、网络ping通的问题已解决,是线插头有点问题,重新拔插一遍好了;

3、WIFI的问题没解决,试了能想到的方式都没有解决,在telnet下手工配置启动也不行
4、地板usbOTG连接到PC后没有反应。
点评回复 支持 反对

使用道具 举报

3

主题

12

帖子

24

积分

i.MX6UL通行证i.MX RT通行证

 楼主| 发表于 2019-4-30 15:43:53 | 显示全部楼层
仔细看了下资料,应该是加密方式的问题导致无法连接AP,我这里的AP不支持wep,现在的驱动有支持wps的吗?

今天事情比较多,还没有对这方面进行测试,由于手中没有RS232转USB的线(几条线都不知道跑到哪里去了),也没办法看debug口的信息,51之后线的就到了,就可以看debug port的输出信息了。
点评回复 支持 反对

使用道具 举报

2

主题

3529

帖子

3196

积分

发表于 2019-4-30 17:31:15 | 显示全部楼层
楼主  建议用wpa加密方式 测试
技术支持电话:0312-3119192
技术支持邮箱:Android@forlinx.com
点评回复 支持 反对

使用道具 举报

3

主题

12

帖子

24

积分

i.MX6UL通行证i.MX RT通行证

 楼主| 发表于 2019-5-3 16:32:39 | 显示全部楼层
本帖最后由 wforest68 于 2019-5-4 22:45 编辑

今天测试还是无法连通wifi,图片发布上来,限制了

按手册操作蓝牙也没成功,前面的操作和手册显示一致,只是别的蓝牙设备搜索不到开发板
更多图片 小图 大图
组图打开中,请稍候......
点评回复 支持 反对

使用道具 举报

3

主题

12

帖子

24

积分

i.MX6UL通行证i.MX RT通行证

 楼主| 发表于 2019-5-5 20:12:07 | 显示全部楼层
今天使用WPA模式连接wifi路由器成功,路由器上能看到设备已经连接,但是却无法ping通路由器,使用其他的电脑也无法ping通开发版,但是不知道为何却能ping通系统配置的DNS服务器,请版主帮忙看一下问题出在哪里??/

还有,配置蓝牙能搜索到其他设备,连接时这个“其他设备”提示输入验证码,输入以后在开发版端没有反应,过一段时间后显示“超时”,我是在console界面下配置的。
3.png
点评回复 支持 反对

使用道具 举报

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|飞凌嵌入式 ( 冀ICP备12004394号-1

GMT+8, 2019-5-26 23:00

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表