嵌入式爱好者

查看: 67|回复: 6

[Linux] 开发板安装nodejs问题

[复制链接]

2

主题

5

帖子

15

积分

i.MX6Q通行证

扫一扫,手机访问本帖
发表于 前天 15:58 | 显示全部楼层 |阅读模式
imx6四核开发板,


uname -a 返回


Linux freescale 3.0.35-2666-gbdde708-00002-g108f810 #1 SMP PREEMPT Wed Dec 25 08:51:28 CST 2019 armv7l GNU/Linux

于是就下载了各个版本的node-linux-armv7l.tar.gz
解压到板子上, bin/目录下运行 ./node -v, 都提示失败:No such file or directory

怎么解决??
回复

使用道具 举报

0

主题

596

帖子

675

积分

发表于 前天 16:27 | 显示全部楼层
给文件可执行权限了吗

点评

权限都给了……777  详情 回复 发表于 前天 16:30
点评回复 支持 反对

使用道具 举报

2

主题

5

帖子

15

积分

i.MX6Q通行证

 楼主| 发表于 前天 16:30 | 显示全部楼层
zhichao 发表于 2020-6-30 16:27
给文件可执行权限了吗

权限都给了……777
点评回复 支持 反对

使用道具 举报

0

主题

596

帖子

675

积分

发表于 前天 16:32 | 显示全部楼层
本帖最后由 zhichao 于 2020-6-30 16:36 编辑

您看看http://bbs.witech.com.cn/portal.php?mod=view&aid=345,再有看看执行路径是不是有问题

点评

就是按照这个步骤来的……跟他的区别就是linux系统是3.0.35,文档是4.1.15……跟版本有关吗  详情 回复 发表于 昨天 10:15
点评回复 支持 反对

使用道具 举报

2

主题

5

帖子

15

积分

i.MX6Q通行证

 楼主| 发表于 昨天 10:15 | 显示全部楼层
zhichao 发表于 2020-6-30 16:32
您看看http://bbs.witech.com.cn/portal.php?mod=view&aid=345,再有看看执行路径是不是有问题

就是按照这个步骤来的……跟他的区别就是linux系统是3.0.35,文档是4.1.15……跟版本有关吗
点评回复 支持 反对

使用道具 举报

0

主题

596

帖子

675

积分

发表于 昨天 10:40 | 显示全部楼层
这个就不太清楚了,我们只在imx6ul的linux4.1.15上验证过,6q和6ul应该有一些差异,您可以在网上查查

点评

好的,谢谢  详情 回复 发表于 昨天 10:46
点评回复 支持 反对

使用道具 举报

2

主题

5

帖子

15

积分

i.MX6Q通行证

 楼主| 发表于 昨天 10:46 | 显示全部楼层
zhichao 发表于 2020-7-1 10:40
这个就不太清楚了,我们只在imx6ul的linux4.1.15上验证过,6q和6ul应该有一些差异,您可以在网上查查

好的,谢谢
点评回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|飞凌嵌入式 ( 冀ICP备12004394号-1

GMT+8, 2020-7-2 20:59

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表