嵌入式爱好者

查看: 463|回复: 1

[Linux] 现有的开发环境缺少所需库函数和支持C++11

[复制链接]

3

主题

3

帖子

15

积分

AM335x通行证

扫一扫,手机访问本帖
发表于 2022-4-21 16:28:22 | 显示全部楼层 |阅读模式
本帖最后由 cai_lhh 于 2022-4-21 16:43 编辑

用户资料的开发环境缺少所需库函数和支持C++11
请问升级qt和交叉编译器需要哪些操作呢?
还有,我能在这块板子上移植64位的ubuntu和交叉编译器吗?


回复

使用道具 举报

0

主题

207

帖子

601

积分

LS1012A通行证LS1043A\46A通行证A40i/T3/T507通行证i.MX8MM通行证RK3399通行证LS1028A通行证AM5718通行证Hi3519A通信证AM335x通行证i.MX6UL通行证i.MX RT通行证i.MX6Q通行证XX18通行证TCU通行证FDU产品通行证FCU1401通行证FCU1301通行证FCU11xx通行证FCU1201通行证FCU2301/FCU2302通行证FCU2401通行证5G转接卡通行证

发表于 2022-4-22 10:38:38 | 显示全部楼层
缺少库的问题,要根据实际情况去安装对应的库;
这边不建议您自己升级qt和交叉编译工具,如果需要升级,对应的linux系统中的库也要对应移植的;
板子上移植交叉编译器行不通,首先板子的内存和存储有限,如果安装编译器加上源码,基本没有空间供用户使用了,ubuntu系列移植到板子上基本上也是运行不起来的;
如果您需要在板子上运行ubuntu系统和交叉编译器,推荐您使用RK3399,这块开发版才能带的动ubuntu系统
点评回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋| 飞凌嵌入式 ( 冀ICP备12004394号-1 )

GMT+8, 2022-5-18 05:48

Powered by Discuz! X3.4

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表